Bienvenido a los foros de FT81x Manía. Te invitamos a regístrate totalmente gratis. Disfruta de tu experiencia con un grandes amigos y Staff.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Thread Contributor: RndMnkIIIRepositorio libreria GD2UB e instrucciones instalación

Shall I #define F103C8T6 in line 24 of GD2UB.h?

by default:
#define __F429ZIT6__ //__F407ZGT6__ __F407VET6__ __F103ZET6__ __F103VET6__ __F103C8T6__ __F429ZIT6__

Shall I change it to:
#define __F103C8T6__ // __F429ZIT6__ __F407ZGT6__ __F407VET6__ __F103ZET6__ __F103VET6__ __F103C8T6__ __F429ZIT6__

The LCD is still blank.

I tried with the following configuration:
INT  No connection

I changed line 13 in GD2UB.h as #define TFT_FT81X_ENABLE   0 //1  

When I upload the sketch into STM32 board via USB to RS232, all seems ok. Just to test, I added the following lines into  example sketch, in order to get some feedback from the STM32 so I would know if it is alive.

void setup()
{ Serial.begin(115200);
 Serial.println("started app");
 Serial.println("after gd.begin()");
 SaidHello.fromtext(31, "FT8XX on STM32F");

When I run the program, I could see the "started app" on serial monitor. But I do not get "after gd.begin()" text on serial monitor. That shows that system stops after GD.begin() command.

I will try to upload screen shot of GD2UB.h config section here.

Thanks for your help.


Attached Files Thumbnail(s)
Please share some pictures of your setup.
Well I going to try with this setup:

Board:  STM32F103VE
Screen: FT801, 4.3"
Breakout-20 from Riverdi
Short protoboard wires


Step 1: 


Step 2: wiring STLink V2

STLinkV2    F103VE   
VCC         3V3
GND         GND


Step 3: wiring VCC to 3.3V and GDN


Step 4: wiring SPI1 to breakout-20, and PD pin to PB1 (POR)

Screen    MOSI1
MOSI      PA7
MISO      PA6
SCK       PA5
CS        PA4
PD        PB1


Step 5: Connect STLink-V2 and micro-USB port in order to get access to serial monitor in the arduino IDE

Short wires

Long wires
        More pictures

Have you used PD or POR?

Oh sorry, I saw you used it at PB1.
Which Arduino IDE have you used?

I have doubt about INT pin. Does it make any difference?
Put the wiring again: wire by wire. This is the key

Show us some pictures of the back of your screen.

Try to feed the screen with external source, that screen I think need a source of 5V
    Here is the back of screen.

Screen has been powered with external +5V source already. I checked the wires again. Same result. I just doubt on Arduino. with 1.8.2 i have many libraries I downloaded earlier. Do you think that could be causing any issue?
Hi @ raufjay 

This afternoon try on my FT800 and MCU STM32F103C8T6 and set example.
(21-09-2017, 11:07 31)lightcalamar Wrote: Hi @ raufjay 

This afternoon try on my FT800 and MCU STM32F103C8T6 and set example.

Ok, I will wait for your outcome. 
Better response on post RE: Repositorio libreria GD2UB e instrucciones instalaciónHello again,

Today morning I tried the same circuit  with the example again. Occasionally I started getting a screen saying "Touch on the Dot" with blue circle as shown in the attached pict. When I touch it, the blue circle disappeared but the text "Touch on the Dot" were there. Thats it. It stops here, no 2nd or 3rd circle appeared any where on the screen.
The calibration screen was showing up occasionally. It does not appear all the time when I press the reset. I tried the same with shorter cables, around 10cm long, but with the same result. I checked all the connection again and again. I replaced the STM32 blue pill, replaced all the cable with new ones, replace the breadboard, the power cables, external power adapter. Tried programming with STlink also. With the same result.

Then I tried with FT811 5" CapTouch LCD. That was better. I mean I could see the touch calibration screen every time I press reset. That means all parts and connections were ok. But with FT800 4.3" screen was upcoming occasionally, but with FT811 5" I see the touch calibration screen comes every time i press the reset.

With FT811 lcd, a blue circle appears on top left with the text saying tap on the circle. When I touch the circle, the 2nd circle comes on right side. After touching this the circle appears on the bottom. When I touch the bottom circle, it stops there only. The circle becomes light blue color and stays there, an animated inward moving white dot, disappears and nothing happens any further. Please see the picture.


I forgot to mention here that when I use the FT811, I edit the line 13 in GD2UB.h to enable FT811 =1.

Forum Jump:

Users browsing this thread: 1 Guest(s)